You are here

Nice SOA2/A vezérlés

2 posts / 0 new
Last post
yohnsee

Sziasztok,

nem voltam benne biztos, hogy javítási tippként vagy fórumbejegyzésként tegyem fel, de utóbbi lett.
A címben szereplő kapunyitó elektronikából hoztak hozzám 3db-ot javításra. Mivel elég sokat küszködtem vele, mire meglett a megoldás, gondoltam megosztom veletek is, illetve hátha valakinek még jól jön egyszer a jövőben.
Hibajelenség: áram alá helyezve az L1 nagyon gyors ütemben villog, mellé a BlueBus led is hibát jelez vissza. Kézikönyv szerint is BlueBus hiba, kapcsolja ki, majd be. Ha ez nem segít, akkor keresse fel a szervizt. A motort és a rajta lévő forgásjeladót apró darabokra szedtem, képeket mellékelem lejjebb. A forgásjeladó szétszedése után kiderült, hogy egy 10 fordulatú potméter van meghajtva a motorról, áttétellel. Itt hívnám fel az első "felfedezésemre" a figyelmeteket, ha nem a fenti hibakód villog bekapcsolás után, hanem az L8 (motor túlterhelés), akkor az egyik lehetséges probléma, hogy ez a potméter az egyik végállásáig el lett tekerve, és hiába indul el visszafele a motor, a potméter tengelyén elcsúszik a hüvely, amibe beleül, és soha nem fog onnan mozdulni. Ezen kézzel segíteni kell, visszatenni és már megy is tovább. Ezt egy korábbi, ugyanilyen típusú vezérlés javításánál vettem észre.
Visszatérve a jelenlegi problémára: az L1 nagyon gyors ütemben való villogása alapvetően kommunikációs hibát jelez, a hiba jó eséllyel nem az alaplapon belüli kommunikáció hibája, hanem az alaplap és a forgásjeladó között lépett fel. Mivel először nem az alaplapra gyanakodtam, mint hibaforrás, ezért elég sok időt eltöltöttem a forgásjeladó kivesézésével. Odáig jutottam, hogy visszarajzoltam a kapcsolást, így azt is megtaláljátok itt. Egy-két szűrőkondenzátor lemaradt, ettől függetlenül a működés lényegét mutatja. A potméter mellett közvetlenül csücsül egy MCP3201 A/D átalakító, aki az alaplappal SPI buszon kommunikál. Külső jelekkel rá tudtam venni, hogy kommunikáljon, így a következő gyanúsítottam az alaplap lett. A bemeneteket mikroszkóp alatt megnézve láttam, hogy ahol ez a jeladó csatlakozik az alaplaphoz, ott 2db BAV99 (2 soros dióda egy SOT-23 tokban, SMD kód: A7W) meg van repedve. Ezek az SPI vezetékeken fellépő nagyfrekvenciás tüskék elnyomásáért felelősek, nélkülük is működnie kellene a modulnak. Sajnos beletelt még egy kis időmbe, mire rátaláltam a hiba igazi forrására, a busz kommunikációhoz szükséges órajel és chip select vonalak nem közvetlenül az alaplapon lévő mikrovezérlőről mennek ki a jeladóhoz, hanem 1-1 BC817 tranzisztor bázisát kapcsolgatják, kollektoruk felhúzóellenállással +5V-ra van kötve, emitterük GND-re. Az órajel és a chip select is a kollektorokra van kötve. Ez a két tranzisztor is meghalt, kicserélve őket azonnal el is tűnt a hibakód, és már programozni is hagyta magát a vezérlő.
Szívesen várom más fórumtársak tapasztalatait is hasonló vezérlések alkatrész szintű javításáról. Ezek az elektronikák (is) mind olyan flash és eeprom tartalommal rendelkeznek, melyek védve vannak, vagy eleve egyszer írható chipben tárolják, de ha netalán valakinek sikerült hozzájutnia ilyesmihez, szívesen olvasnám a hozzászólásait a hogyan-okról.

File attachment: 
Comments