You are here

Onkyo tx-nr646 no power

Fuses are all good. Dosent turn on at all. I have 12volts on stb power pin 4 of power supply. Relay rl9001 on power supply board is not turning on. Relay is good. Has 12 volts positive on the relay. I’m assuming mpower goes to ground and triggers relay. This isn’t happening. I can short out relay to let 110 volts thru and receiver powers on and seems to work. Any info on troubleshooting would be appreciated. 

Comments
Ambrosia Heart

Fuses are all good. Dosent turn on at all. I have 12volts on stb power pin 4 of power supply.

OK. Now, download NR646 service manual. See p.52 A4 measure Q8975 vin and V out. Measure Q7018 Vin and V out. Jot down here.

Relay rl9001 on power supply board is not turning on. Of course, Q7009, main micom not working.

0

Vote up!

You voted ‘up’

Gmonarch

I can find q7009 but I cannot find either one of those transistors. I don’t even see them on the component layout. I’m assuming they are by q7009 Somewhere. 

0

Vote up!

You voted ‘up’

Ambrosia Heart

I can find q7009 but I cannot find either one of those transistors.  

Next to the Words +3.3_V STB,  right hand side 
bottom corner.  They are not transistors, but
SMPS regulator.

0

Vote up!

You voted ‘up’

Gmonarch

I also can’t find Q8975 in the Onkyo parts list in the back of the repair manual. Yet it is on the print. 

0

Vote up!

You voted ‘up’

Gmonarch

I didn’t realize they were on the underside of the board. The 7018 has 5 in and 3 out. The 8975 there is no chip there. Do u have a email I could send a pic to. Or my email is gary@abelelectronics.com

0

Vote up!

You voted ‘up’

Ambrosia Heart

email sent with title onkyo.

0

Vote up!

You voted ‘up’

More similar content