You are here

Qnap TS-509 Pro hálózati merevlemez (NAS) nem kapcsolódik a hálózatra egyik UTP porton sem.

11 posts / 0 new
Last post
Babuci58
Babuci58 picture

Sziasztok!

Szeretnék segítséget kérni a fenti eszköz alalplapi ethernet kapcsolatának megjavtásához.Lemondtak róla, úgy
került hozzám, de szertén feléleszteni. Mivel speciális eszközről van szó donort szinte biztosan nem tudok
beszerezni. A NAS bekapcsolás után elindul, a Qnap operációs rendszere rendesen betöltődik. Két gigabites UTP
csatlakozója van, ha bármelyikbe élő hálózati kapcsolatot dugok látszólag a kapcsolat létrejön. Az UTP aljzat
Ledjei villognak és az előlapi hálózatjelző led is villog.
De a hálózati kapcsolat nem jön létre, nem lehet a Nas webszerverébe belépni. Router oldalról sem látszik, nem
ping-elhető. Reset-et látszólag rendesen megcsinálja az LCD kijelzőre kiírja az IP címét de nem elérhető.
Ennek az eszköznek az operációs rendszerét egy 128MB-os Disk On Modul tárolja, illetve a beépített
merevlemezek.Alaplapja Intel processzoros, 1GB RAM-mal.
Az eredeti operációs rendszer Linux alapú,de nem szabadon hozzáférhető. Ezért egyik USB portjára CD-t kötve
elindítottam egy Ubuntu Live CD-ről. Itt már sikerült a hálózati eszközök beállításához hozzáférni. Be lehetett
állítani fix IP címet DHCP-t, de ha a kábelt beledugtam a számítógép nem látta többet a "kártyát" lekapcsolódott a
PCI buszról. Ezt a vonalat feladtam, nem vagyok nagyon Linux értő.
A neten keresgélve a Broadcom BCM5787MKHLG chiphez létezik tesztprogram DOS illetve Win2008Server-hez.
A Disk-On-Modul helyére egy megfelelő átalakító közbeiktatásával sikerült egy Compact Flash kártyát berakni amin
DOS van. A tesztprogram mindkét kártyát hibásnak találja különféle regiszterek hibáit írja ki. A program elvileg
képes a BCM chipek firmverjét frissíteni, de ehhez kellene a megfelelő file, illetve a program szerint valamiféle
jelszó.A Broadcom chipek környékén van 1-1 Atmel soros eeprom gondolom ezek tárolják a konfigurációt. mindkettő
kiolvasható, tartalmuk szinte teljesen azonos. Két eltérés szerintem az egyik a PCI címe a másik a mac address.

Esetleg tudnátok segíteni megfelelő bootloader, flash, eeprom tartalommal illetve hogy hogyan tudom frissíteni a
tartalmakat.Először megpróbálnám a szoftveres rész cseréjével helyreállítani a működést.
Ha ez nem sikerül a következő a chip cseréje lesz, de nem tudom ha vásárolok új chipet (ebay-en találtam) lesz-e
benne program, illetve hogyan fogom beállítani.
Kérem aki már csinált hasonló műveletet segítsen!

Köszönöm:
Laci

Comments
lcsaszar
lcsaszar picture

Szia!

Azt próbáltad, hogy direktben rákötsz egy PC-t fix IP címmel ugyanabban a hálózatban, ami a gyári alapbeállítás szerinti? Tehát nem a routeren keresztül, hanem egy crossover UTP kábellel. Innen már lehet vizsgálódni, pl. Wireshark-kal.

Üdv, lcsaszar

0

Vote up!

You voted ‘up’

Babuci58
Babuci58 picture

Szia!
Linuxos rendszeren tudtam némi infót szerezni a hálózat állapotáról. Próbáltam sima és Crossover kábellel is egy laptoppal rácsatlakozni. Amint az UTP kábelt bedugom a kapcsolatjelző ledek villognak kb 1 percig, de a hálókártya eltűnik a Linux sem látja. Ha a másik aljzatba dugom akkor ott is ugyanez a helyzet. Azt jelzi hogy a kártya lekapcsolódott a PCI express buszról.

0

Vote up!

You voted ‘up’

lcsaszar
lcsaszar picture

Gombelemet kivesz/visszatesz, reset gombot 10 másodpercig nyom, akkor sem? Azért az érdekelne, hogy milyen hálózati aktivitás zajlik az alatt a bizonyos 1 perc alatt... Wireshark, csak ezt tudom javasolni.

Üdv, lcsaszar

0

Vote up!

You voted ‘up’

Babuci58
Babuci58 picture

Szia.
Csak este felé tudok vele foglalkozni, ezt a wireshark dolgot megpróbálom. Gondolom ehhez vissza kellene állítanom az eredeti operációs rendszerre. Mit kellene tapasztalnom?
Köszi:
Laci

0

Vote up!

You voted ‘up’

lcsaszar
lcsaszar picture

Szia,

Kellene látni DHCP-t, ARP-ot. Ha a PC-ről pingeled az IP címét, vagy próbálsz rámenni a webes admin felületre, akkor valami válaszcsomagnak is kell jönnie, abba is bele kellene nézni.

Üdv, lcsaszar

0

Vote up!

You voted ‘up’

Babuci58
Babuci58 picture

Szia!
Köszönöm a segítséget. Visszatettem az alaplapba a Disk modult és elindítottam az eredeti rendszert. Betöltődik kiírja az IP címet. Előtte egy PC IP címét beállítottam 192.254.100.1-re és elindítottam a Wireshark-ot.
A két LAN portban a csatolt forgalmat rögzítettem. Mintha nem válaszolna semmire, bár nem annyira értem a csomagok jelentését. PING-re nem válaszol, a Qnap finder sem találja. Webes felületre nem tudok bejelentkezni.
Köszi:
Laci

File csatolás: 

0

Vote up!

You voted ‘up’

agressiv
agressiv picture

Üdv

Valószínáleg hibás a Broadcom IC, cserélni kell. Tápfeszt kap rendesen?

0

Vote up!

You voted ‘up’

Babuci58
Babuci58 picture

Szia!
Igen a tápja rendben van, 3,3V. Szkóppal nem néztem, de tettem rá egy 470uF-os kondit, semmit nem változik.
Szerintem és a DOS-os tesztprogram szerint is beteg a chip. A kérdés ha veszek újat lesz-e benne szoftver.
Mert a firmware frissítéshez kellene bináris file, illetve valamiféle jelszó a DOS-os program szerint.
Köszi:
Laci

0

Vote up!

You voted ‘up’

lcsaszar
lcsaszar picture

Szia,

Az látszik ebből, hogy a QNAP valóban nem kommunikál. Már amennyiben direktben volt összekábelezve a PC-vel, és nem routeren keresztül. Na de akkor hogyan fotóztad a login screent :?

Megpróbálhatsz még a PC-nek fix IP címet adni, pl. 192.168.1.1, és elindítani egy DHCP szervert, ami a 192.168.1.0/24 hálózatból oszt IP címeket. Ha a QNAP kap IP címet, akkor az már jó jel. A 169.254.x.x úgynevezett automatikus IP cím, amit akkor vesz fel egy eszköz, ha sem fix IP cím nincs konfigurálva, sem DHCP-től nem kap címet.

Üdv, lcsaszar

0

Vote up!

You voted ‘up’

Babuci58
Babuci58 picture

Szia!
A laptop és a nas között csak egy szál crossover kábel volt. A nas-nak van egy szerviz portja, ez egy vga csatlakozó. Ha erre kötök monitort azon látszik a boot folyamat, a Dos és Linux programokat is így tudom futtatni. A különbség annyi hogy az eredeti QTS oprendszerrel nem kezeli az usb billetyűzetet a többi viszont igen.
Így tudtam a dos-os tesztprogramot is futtatni vagy elindítani Linux live cd-ről.
Az Ip címről e kezelési könyv ezt írja:
Note: The default NAS IP is 169.254.100.100:8080. If the NAS has been configured to use DHCP, you can use QNAP Qfinder Pro to check the IP address of the NAS. Make sure the NAS and the computer that runs QNAP Qfinder Pro are connected to the same subnet. If the NAS cannot be found, connect the NAS to the computer directly and run QNAP Qfinder Pro again.
A dhcp szervert letöltöttem, csak sajnos tegnap nem tudtam vele foglalkozni.
Köszönöm a segítséget:
Laci

0

Vote up!

You voted ‘up’

More similar content