You are here

Rotel RA-820A stereo amplifier, crackling noise

I'm hoping someone here can give me some guidance with regards a possible fix for this amplifier.
A friend has brought it to me with this problem. I removed the case and there are obvious signs of damage, which looks like water ingress as the board looks rusty. Particularly around a cap, a diode and a resistor.

I have obtained the circuit diagram from here but it is a long time since I did electronics at collage.
Other than the rust coloured spot there are no other signs of damage. The cap doesn't look blown at least but would it be advisable to replace all three components?
Would a simple clean up potentially fix the problem since it is outputting, just not correctly.
Maybe the rusty area has created a minor short?
Any advise would be greatly appreciated.
Thanks in advance.

Comments
hifista
hifista picture

Hi!
That much information is not enough.
Since this is a stereo amplifier, there is a good channel to which you can compare the bad.
The appropriate values ​​must be measured
And "a picture says more than a thousand words"
Hifista..

0

Vote up!

You voted ‘up’

tibor555
tibor555 picture

Hi,
A rusty "waters" around the elkos refer to the damage of them.
The minimum to replace the leaked elkos and you will see it is enough or not.
Of course it my happen the leaked electrolit pull away the optimal adjustment of the amplifier. In that case you have to remove it carefully.
( In order to save the amplifier from any possible damage in the future I'd remove it anyway).
Regards
Tibor

0

Vote up!

You voted ‘up’