You are here

CH341A programozó nem akar működni

10 posts / 0 new
Last post
jancsika

Jó napot mindenkinek--lenne ez a-mondjuk kínai féle-programozó,és habár xp-n és windows 10-en is próbáltam,nem akar működni,ha az USB-be bedugom és kihúzom azt észleli a windows,és eszközkezelőben látja a portot,ez a programozó alkalmazásban sehol nem jelenik meg,no persze a -device not connect-felírat mindig ott van,esetleg ha valami trükkel kell telepíteni szívesen fogadok minden segítséget,elsősorban XP-n,tudom régi de ezt a rendszert jobban ismerem és programozni jó ez,úgyse nézek HD videókat programozás közben...a programozón van egy jumper,nem tudom azzal kellene tenni valamit vagy sem....akár XP,akár windows 10 kérem lépéseket megadni,én már sokféleképpen próbáltam,de nem akar jóba lenni velem...köszönöm a figyelmet...

Comments
pumi

Szia!

Ha valaki nem ismerné..
Feltöltöttem ide:

https://elektrotanya.com/CH341A_Colibri_program.zip/download.html

"A programozóval való együttműködés során néhány hiányosságot tárt fel,
egyikük: nem lehetséges a QE bit visszaállítása / beállítása a második állapotregiszterben.
Adatlapot olvasunk, például egy W25Q64FV chipen, és a Quad Enable (QE) ,
amelyben van egy figyelmeztetés:
FIGYELMEZTETÉS: Ha a / WP vagy / HOLD csapok közvetlenül a tápegységhez vagy a földhez vannak kötve
szabványos SPI vagy Dual SPI művelet esetén a bit soha nem állítható 1 értékre.

A hiba kijavításához le kell szedni a #WP (3. pont) és a #HOLD (pin7) lábakat a VCC-től 
és csatlakoztassuk őket VCC-hez a 4.7 com ellenállásokkal.
A "fekete programozón" ez így néz ki:"

 

File csatolás: 

0

Vote up!

You voted ‘up’

pumi

Szia!

Tapasztalat alapján, nálam a 1.29 verzióval működik hibátlanul.. felismeri automatikusan a chip-et.
Van egy 1.4 free verzió, ami működik, de kevésebb infót ad.
Az 1.30 verzió hibát generál. Úgy vettem eszre a 1.29 alatti verziók is működnek... /1.18/
A jumper maradjon az 1,2 -n :-)

0

Vote up!

You voted ‘up’

Andor-2

Szia!
Én is szenvedtem annak idején.
Én innen töltöttem le ami végre normálisan működik:
https://www.laboneinside.com/ch341a-mini-programmer-software/
Sok sikert.

 

1

Vote up!

You voted ‘up’

Jaca
Jaca's picture

Szia!

Dugd be a programozót, és az eszközkezelőben nézd meg az eszköz tulajdonságait. Az egyik fülön kell lenni egy vid és egy pid számnak (hexában), ahhoz keress drivert (például vid 12d1 pid 107e).

1

Vote up!

You voted ‘up’

jancsika

Szia--igen,vid és pid szám alapján letöltött driver alapján el is indult,olvasni olvas jól,viszont írásnál a végén kiír valami olyasmit hogy chip disagrement write,és persze a tartalom nem jó...most ehhez kérnék segítséget....

0

Vote up!

You voted ‘up’

mosomedve
mosomedve's picture

Valóban, a végén elvégez egy ellenőrzést és ha különbséget talál a programozandó és a vissza ellenőrzött között hibaüzenetet ad. Meg kell próbálni előbb törölni a chippet és még azt is vissza ellenőrizni a Blank utasítással és ezután megpróbálni újra írni. Ha ezután sem megy három dolog lehet: valóban rossz a driver, rossz a chip amibe írni akarsz vagy már hibás maga a programozó. (nekem már sikerült egyet elhasználni rossz rákötés miatt, már van belőle három darabom, ha legközelebb is elbaltázok valamit.
László

0

Vote up!

You voted ‘up’

jancsika

Szia--holnap megpróbálom,de minél több ötlet érkezik annál jobb...üdv....

1

Vote up!

You voted ‘up’

jancsika

Sziasztok--nos sok kínlódás után a tegnap el kezdett működni,igaz próbálkozik 7-8-szor írásnál,de végül megírja...üdv.

0

Vote up!

You voted ‘up’

KézdyA

Lehetségesnek tartom hogy az USB portod nem tud elegendő tápáramot biztosítani és ezért bizonytalan az írás üzemmód.
Próbálkozz külső táplálással!
Nálam pl. a laptop USB portjai nem bírják egyszerre a külső HDD-t és a Mifi-t.

1

Vote up!

You voted ‘up’

More similar content