You are here

Nixie cső hiányos kijelzés (MEGOLDVA - műhiba volt!)

35 posts / 0 new
Last post
cape-t
cape-t's picture

Sziasztok!

Megépítettem a mellékelt kapcsolást, de nem működik tökéletesen. A katódok nem gyújtanak be teljesen, hiányosak a számjegyek.

Próbából a csövek katódjait egyesével (a meghajtó IC nélkül) közvetlenül a VSENSE ágra kötöttem és így mindegyik számjegy szépen világít, a feszültség az anód és bármelyik katód között 140V körüli. Ha az IC-n keresztül hajtom a csöveket, a feszültség kb. 90V-ra esik vissza. (A COM kivezetéseken a rajznak megfelelően ott az 50V) Az IC-ket Kínából rendeltem. Lehet, hogy hamisítvány?

A nyákot már sokszor leellenőriztem, elkötés nincs. Cseréljem a megható IC-ket, vagy mit érdemes még ilyenkor megnézni?

Minden tanácsot előre is köszönök.

Szerk:
Sziasztok!

Mindkét probléma oka műhiba volt! Az összedrótozáskor nem kötöttem be a TILTP vezetéket (uC 20. lába), gondolván, hogy a gyorsulásmérőre még nincs szükség. Azt viszont nem vettem figyelembe, hogy ez a láb kijelzés közben a nagyfeszültséget is kapcsolgatja. A vezeték bekötése után normalizálódott a kijelzési kép és R5 értéke is maradhatott a rajz szerinti 150R.
Mellékeltem szkópábrákat. A sárga CH1 csatorna a uC 20. lába. Ha ez a kimenet magasban van, a nagyfesz lecsökken kb. 120V-ra (a csövek kikapcsolva), ha 0-ban van, akkor megjön a 140V, bekapcsol az adott cső. (tízes és egyes helyiérték felváltva.) A kék a 10-es helyiérték (42% kitöltéssel) a rózsaszín az 1-es helyiérték (57%-al) meghajtása. A három jel metszetéből látszik, hogy a nagyfesz mindkét cső esetén ~6mS ideig van engedélyezve így az eltérő kitöltési tényező ellenére is egyforma ideig világítanak a csövek. Azt mondjuk nem értem teljesen, hogy R5 pozícióban a 150R-al hogyan lett most mégis ~2mA az össz. áram (290mV-ot mérek az ellenálláson), de mindegy is. A szerkezet működik!

Köszönöm mindenkinek a segítő szándékot!

Üdvözlettel:
Gyula

Üdv:
Gyula

 

Comments
cape-t
cape-t's picture

Sziasztok!

A hiányos karakterek kérdése megoldódott az R5 áramfigyelő ellenállás csökkentésével. Van viszont másik probléma.

Az egyes helyiértéken levő (jobb oldali) cső erősebben világít és lilás-kékes derengést tapasztalok. (Lás kép) A csövek megcserélésével kezdtem, de a hiba maradt a jobb oldalon.
Cseréltem már a meghajtó IC-t, de semmi változás. Az anódáram a "jó" oldalon 650uA az erősebben világító csőben 920uA (Nyilván ebből adódik a fényerő külömbség). "44" kijelzési képnél a jobb oldali aktív katódon 10,1V-ot mérek a "hibáson" 6,5V-ot. A nem aktív katódokon a jó oldalon 60V körüli feszültségek vannak, a hibás oldalon 40V körüliek. Próbáltam soros ellenállást beiktatni az anód elé, de ekkor a karakterek hiányosak maradtak, a lilás-kékes derengés viszont nem tűnik el. Próbáltam az ellenállást a meghajtó IC 9. lábával sorba is (csak a hibás ágon), de így számot tevő változást nem tapasztaltam.

Mit lehetne még kipróbálni, hogy a kijelzési kép egyenletesebb legyen?

Köszi!

Üdv.
Gyula

File csatolás: 

0

Vote up!

You voted ‘up’

Guest
Guest's picture

A katódokat meghajtó darlingtonok a PIC portjai felől állandósult szintű vezérlő jelet kapnak vagy impulzust ?

0

Vote up!

You voted ‘up’

cape-t
cape-t's picture

Szia!

Azt hiszem most Neked jár a pont. A bal oldali cső 63Hz 42% kitöltésű négyszögjellel van hajtva, a jobb oldali 63hz 57% kitöltésűvel. Így már logikus a nagyobb áramfelvétel és a fényesebb kijelzés. Viszont a FW-t nem én írtam (Assembly), ezért nem biztos, hogy ki tudom javítani...

Üdv:
Gyula

0

Vote up!

You voted ‘up’

Jaca
Jaca's picture

Szia!
Invertáld meg az egyik kimenetet, és akkor az 57-ből 43 lesz, vagy a 42-ből 58.
De ha átküldöd az FW-t, meg hogy pontosan melyik kimenetet kell változtatni, megnézem, hátha sikerül.

0

Vote up!

You voted ‘up’

cape-t
cape-t's picture

Szia Jaca!

Köszönöm a felajánlást! Élni fogok vele. A FW-t most elküldöm, de hogy mit-hol szeretnék változtatni, azt még nem tudom pontosan. Még jelentkezem, de azt szerintem már privátban.

Üdv:
Gyula

File csatolás: 

0

Vote up!

You voted ‘up’

Jaca
Jaca's picture

Szia!

Kiírja az első digitet, aztán kiírja a második digitet, és lekérdezi a gombokat, majd kezdődik előlről. Ezért a második digit kiíratása hoszabb lesz. Nem tudom, mi a jobb, ha beteszek az első digit után egy delay-t, vagy ha ott is lekérdeztetem a billentyűket.
Kipróbálod, és eldöntöd.

Közben még nézegettem a programot, és lehet, ez a jelenség csak addig áll fenn, míg be nincs állítva az idő. Csak a szimulációban még nem jutottam el odáig.

File csatolás: 

0

Vote up!

You voted ‘up’

cape-t
cape-t's picture

Szia Jaca!

Neked külön köszönöm, hogy foglalkoztál vele! Viszont a probléma oka műhiba volt. Lásd fentebb.

Üdv:
Gyula

u.i.: Azért kíváncsiságból lehet ki fogom próbálni a Te verziódat is és majd referálok.

0

Vote up!

You voted ‘up’

Jaca
Jaca's picture

Szia Gyula!

Azt néztem én is, hogy a tilt szenzor értékétől függően lép át egy másik loop-ba, ahol lehet, már jó a kijelzés.

Üdv: Jácint

0

Vote up!

You voted ‘up’

Guest
Guest's picture

A fényesebb cső anódkörébe ha beteszel egy soros plusz ellenállást, az egy szintre hozhatja a két cső fényerejét anélkül hogy bele kelljen piszkálnod a szoftverbe.

0

Vote up!

You voted ‘up’

cape-t
cape-t's picture

Szia!

Azt már próbáltam, de sajnos nem igazán segített. A karakterek szélei már kezdtek eltűnni, de a kékes derengés még mindig megvolt. Inkább a FW módosítást látom célravezetőnek.

Üdv:
Gyula

0

Vote up!

You voted ‘up’

Mosószaki
Mosószaki's picture

Vidd arrébb a tápot próbára!

0

Vote up!

You voted ‘up’

guriga
guriga's picture

Hova vigye? Ez már cső hiba.

0

Vote up!

You voted ‘up’

Mosószaki
Mosószaki's picture

A csövek megcserélésével kezdtem, de a hiba maradt a jobb oldalon

Kapcsoló üzemű a táp...
A gáztöltésű csövek a elektromágneses térerőre hogy reagálnak?

0

Vote up!

You voted ‘up’

cape-t
cape-t's picture

Szia!

Köszönöm az idézetet! Mivel még vezetékeken lóg minden, megpróbálom elmozgatni a csöveket. Mert valóban a jobb oldali cső közelebb van a táphoz. Viszont ha ez a hiba oka az gáz, mert a design már nem változhat.
Érheti károsodás a csövet, ha esetleg tartósan így marad? A csőáram ~1mA a feszültség 145V. Mert a NYÁK-ot már legyártattam és nem szívesen módosítanám.

Üdvözlettel:
Gyula

0

Vote up!

You voted ‘up’

Mosószaki
Mosószaki's picture

Nem.
De nehezen lehet leárnyékolni. Vagy elsőre sikerül egy csokipapírral (alufólia) vagy kínlódhatsz vele vért izzadva, mire elfogadható lesz...

0

Vote up!

You voted ‘up’

cape-t
cape-t's picture

Köszi a választ. De úgy néz ki, a FW okozza. Lásd fentebb.

Üdv

0

Vote up!

You voted ‘up’

SzBálint
SzBálint's picture

szia: ha a táp közelsége okozza, egy vékony lemezzel tudod ideiglenesen árnyékolni, esetleg testelve
(tuner teteje, konzervdoboz, bontott winchester fedőlemeze)

Bálint

0

Vote up!

You voted ‘up’

Guest
Guest's picture

0

Vote up!

You voted ‘up’

cape-t
cape-t's picture

Szia!

Ott pont a derengés volt a probléma, mert csak egy csővel próbáltam és nem evvel a típussal. Sajnos a meghajtó IC-k is más típusok voltak a "deszkamodellben", így nem tudom az-e a gond.
Most pedig halványak a karakterek...

Üdv:
Gyula

0

Vote up!

You voted ‘up’

gbenyov
gbenyov's picture

OK! Látom, hogy csuda dolgok vannak...

0

Vote up!

You voted ‘up’

gbenyov
gbenyov's picture

Szervusz Gyula!
A dolog igen egyszerűen bemérhető:
VAN-E:
1. Nixie közös anódon folyamatos világítás mellett kb. 140V?
2. Nixie éppen bekapcsolt katódon max. 2V?
3. TDA 10-es lábán kb. 50V?
4. TDA   9-es lábán 0V?
5. Az éppen bekapcsolt TDA bemeneten max. 2V?
HA EZEK MEGVANNAK, AKKOR NEM LEHET GOND.
Vagy mégis van?

 

0

Vote up!

You voted ‘up’

cape-t
cape-t's picture

Szia!

Az 1., 3. és 4. pontok teljesülnek. Az 5. ponthoz: a TD bemenetekre a kontroller elvileg 3.3V-ot kapcsol. (Adatlap szerint min. 2,5V kell neki.) Mivel mindig a megfelelő számjegy gyújt be, úgy gondolom, hogy a uC felől a meghajtás rendben van.

A 2. ponttal van a probléma. A katódon kb. 50V-ot mérek. Így jön ki a 90V az anód és katód közt, ami szerintem igencsak kevés.

A kérdés, hogy miért ilyen nagy a TD tranzisztorán a maradékfeszültség?

Üdv:
Gy

 

0

Vote up!

You voted ‘up’

Attee

Üdv!

Öhöm... Akkor én más adatlapot néztem, mert eszerint a TD62083 TTL szintet vár, min. 3,5V-ot...Lehet, hogy nyit kevesebbel is valamennyire, de a kimeneti áram nem lesz elég a nixie-knek. Talán a sima, nem TTL változattal működne (TD62081 + külső bázisellenállás) (?)

0

Vote up!

You voted ‘up’

Guest
Guest's picture

A kapcsoló darlingtonok emitterei nem a GND-n hanem az R5 figyelő/korlátozó ellenálláson eső feszültséggel megemelt potenciálon vannak.
A problémád az okozhatja hogy a cső begyújtásakor nagyon visszaszabályoz a DC/DC converter. Az R4 helyére tegyél egy 20-50 kOhm trimmert amivel beállíthatod a szükséges mértékű visszaszabályzást.

0

Vote up!

You voted ‘up’

cape-t
cape-t's picture

Szia!

Bálint megjegyzésére reagálva (~öregebb csőnek több áram kell) első körben az R5 áramfigyelő ellenállást csökkentettem (egy párhuzamos 220R-al) 90R-ra. Ezzel növeltem a csövek áramát és nyilván a nagyfesz. is emelkedett 145V-ra. Most úgy néz ki jobb a helyzet.

Csinálok majd képeket is, ha odajutok.

Köszi a segítséget.

Üdv:
Gyula

0

Vote up!

You voted ‘up’

Attee

Üdv!

Én azért még nyomoznék egy kicsit. És lehet, hogy mégiscsak tennék bele ULN ic-t, a 2803A-nak tutira elég a 3,3V, (2,5V)  míg a TD62083AF az adatlap szerint minimum 3,5V-ot igényel. Azt mondod, ULN-nel ment is gyönyörűen.Ráadásul  nem kell kínából rendelni...Mivel a lábkiosztás is stimmel, még át sem kell alakítanod....
 

0

Vote up!

You voted ‘up’

cape-t
cape-t's picture

Szia!

Az ULN-eket még a deszkamodellben próbáltam más típusú csövekkel. Sajnos a B5870 csöveket ebbe nem próbáltam bele és sajnos már szétszedtem. (Néhány alkatrészt átemeltem belőle a végleges panelre.)
A hely miatt csak SSOP16 tokozás jöhet szóba. Gondoltam a TBD62083AFNG-re mint esetleges kiváltó típus. Mi a véleményed? (Fentebb megírom a mérési eredményeket is.)

Köszi:
Gyula

0

Vote up!

You voted ‘up’

SzBálint
SzBálint's picture

szia: a tápban a két 10 nF-et cseréld 22nF-re, lehetőleg stiroflexre
Elég a táp teljesítménye?
A megöregedett Nixie csövek pedig  nagyobb anódáramot igényelnek

Bálint

0

Vote up!

You voted ‘up’

gbenyov
gbenyov's picture

Szia SzBálint!
Jó, hogy mondod...
1 db. 10nF 50Hz-en több száz kiloohm! Nem tévedés-e ez az érték? Nem inkább 1uF-ekre lenne szükség itt?

0

Vote up!

You voted ‘up’

cape-t
cape-t's picture

Szia!

Melyik kondikra gondolsz pontosan? A nagyfeszt. egy kapcsoló üzemű (LT1308B IC-vel) táp állítja elő 3,7V-os akkuból kb 600kHz-en. A deszkamodellt Z570-es csövekkel és ULN2803 IC-vel építettem meg. Az teljesen jól működött. Ebből azt feltételezem (lehet, hogy tévesen), hogy a nagyfesz. táp rendben működik. A 140V is megvan begyújtott csöveknél.

Üdv:
Gyula

0

Vote up!

You voted ‘up’

gbenyov
gbenyov's picture

Bocsánat! Nem voltam elég figyelmes! Tévedtem! A 10 nF 500-600kHz-en néhány ohm. Tehát teljesen megfelelő.
Meg van terheléssel is a 140V=ez jó.
Amennyiben ellenőrizted, hogy ez a "bonyolult" IC valóban kap földet és valamint a darlington tranyók bemenetén stabilan van 2V-nál nagyobb, pl. 3,5V nyitófeszültség, akkor a NIXIE csövek néhány milliamperes áramát kisebb mint 2V-ra KELL lehúznia! Én nem gondolom, hogy rossz az IC. Az nem lehet, hogy MINDEN kimenete egyformán rossz lenne!


(Vicces, de nem lehetne kihagyni a TD-t? A helyére legalább egyetlen kimenet esetébe betennék próbára 1 db. 200V-ot tűrő tranyót, plusz egy soros 2,2 kOhmmal a bázisában....)

File csatolás: 

0

Vote up!

You voted ‘up’

cape-t
cape-t's picture

Szia!

Köszi a válaszod! A halvány karakterek kérése az R5 ellenállás csökkentésével már megoldódott, de van más probléma is. A hibát és a mérési eredményeket lásd feljebb.

Üdv:
Gyula

0

Vote up!

You voted ‘up’

SzBálint
SzBálint's picture

szia: C3, C4

Bálint

0

Vote up!

You voted ‘up’

Guest
Guest's picture

Még véletlenül se zavarjon hogy a nixie csöveknek egy fix. 600 kHz-en üzemelő boost converter állítja elő a tápfeszt!
https://www.analog.com/media/en/technical-documentation/data-sheets/1308i.pdf
Nem csak írogatni, olvasni is tessék!

0

Vote up!

You voted ‘up’

More similar content