You are here

PicKIT2 vs. WIN7 32bit. Esetleg nem szeretik egymást? (Megoldódott!)

15 posts / 0 new
Last post
Isaac
Isaac picture

Sziasztok!
Az alábbi problémám lenne:

Csatlakoztatom a Pickitemet (clone) a géphez a windows felismeri és felrakja a drivert.

Ha a pickit progi nincs elindítva semmi gond.

Ha progi el van indítva és utána csatlakoztatom az eszközt a géphez, akkor kiírja hogy probléma lépett fel a csatlakoztatásnál.

De ha előbb az eszközt csatlakoztatom először akkor a win felismeri, de a progit nem tudom elindítani. A feladatkezelőben pedig ott a pickit2.exe, de nem látszik az asztalon semmi.

A mai nap folyamán kezdte az egészet. Egész eddig jól működött minden.

Újra raktam a windowst és a pickit progit is. Mert azt hittem hogy a WIN hülyűlt meg, de sajna nem jött össze.

Szerintetek? Lehet hogy a gépnél is hehet valami (USB). Mert a pendrive-okat is sokára tölti be a windows.

Comments
Isaac
Isaac picture

Sziasztok!
Bocs hogy ilyen későn, de most jutott eszembe.

BBGAMES-nak volt igaza!
Sajnos nem tesz jót a PICKIT-nek ha be van dugva és kikapcs a gép.

De most legalább ezt is tudom.

Ezért beszereztem még egy PIC18F2550-et meg is írtam, hátha ismét elfelejtkezek kihúzni leállítás előtt a hardwert.

Azért köszönöm mindenkinek a fáradozását.

0

Vote up!

You voted ‘up’

ppeti84
ppeti84 picture

Szia.
Én is win7 32bit rendszerrel használom napi szinten a pickit2 klónomat.
Ott a géppel lehet esetleg valami bibi.
Próbáld ki egy másik gépen mit szól hozzá.

0

Vote up!

You voted ‘up’

Isaac
Isaac picture

Halihó!

De tudjátok mi a fúrcsa?

Hétfő este még programoztam 2 különböző PIC-et, végeztem gép kikapcs, ki se húztam az USB toldóból az eszközt.

Másnap gép bekapcs, azt semmi........ Elkezdet sz@rakodni!

Ja és még annyi, hogy a rendszereszközöknél USB-HUB -kén kellene szerepelnie mint eszköznév?
Mert amikor működött akkor nem is néztem ezt.

0

Vote up!

You voted ‘up’

CodeKiller
CodeKiller picture

Üdv,

Én gyanítom, hogy az alaplap, vagy az usb vezérlő (netán a táp) döglődik.
Megpróbálhatnád másik gépben és/vagy pci-usb kártyával működik-e.

üdv,
ck

0

Vote up!

You voted ‘up’

BlackForce
BlackForce picture

Üdv!
Nekem is van klónom és win7 alattis meg xp (32bit) alatt is megy simán pickit2 v2,61-es verzióval.

0

Vote up!

You voted ‘up’

nantal
nantal picture

Alaplap driverek okésak?
Próbáld meg régebbi Pickit2 software verziókkal, itt találsz néhányat.

0

Vote up!

You voted ‘up’

Isaac
Isaac picture

Próbálkoztam alaplap driverekkel, és különbözö PicKIT szoftokkal is, de változatlan.

0

Vote up!

You voted ‘up’

lhanzi
lhanzi picture

Szia!

Én Win7 64bittel használom gond nélkül a saját progijával, bár az én PicKit2-öm eredeti. Semmilyen gond nem volt a telepítésnél! Még új softot sem szedtem le, azt használom mint Xp alatt! PicKit 2 v 2.61

Leiszt Jani

0

Vote up!

You voted ‘up’

bbgames
bbgames picture

Az MPLAB alatt használod?

üdv
bbgames

0

Vote up!

You voted ‘up’

Isaac
Isaac picture

MPLAB...... Semmi. :(

Kipróbáltam itt is különböző verziókat, de nem jött össze.

A programozó választásnál ráadásúl mid a kettő pickit inaktív.

0

Vote up!

You voted ‘up’

bbgames
bbgames picture

A pickit2-t soha ne hagyd benne kikapcsoláskor a gépben, mert megsérülhet benne a firmware.
Nálam kétszer kellett újraírni (a CHIPCAD-nél megcsinálták), miután mindig kihúztam, ez a hiba megszűnt.
Másik USB eszköz is zavarhat, nekem pl. a CANON IP5200 printer zavarja a PICKIT3-at.
MPLAB alatt a connect-nél látszik mikor frissíti a firmware-t (ha korábban más módban volt használva) engem ez nyugtat meg, hogy minden OK.
Munka közben, mikor programmer és debugger között váltok, gyakran ki- be kell csatlakoztatni az eszközt, mert a connect-nél megáll az MPLAB

üdv
bbgames

0

Vote up!

You voted ‘up’

Isaac
Isaac picture

Úgy néz ki neked van igazad!
Összeraktam egy másik gépet, ugyan az a helyzet.

A hét folyamán ha lesz időm akkor újraírom a firmware-t.

+ Még elő kell ásnom a régi PIC égetőmet.

0

Vote up!

You voted ‘up’

Isaac
Isaac picture

Sajna nem találom a régi égetőmet. Ezért összeraktam egy ART2003-ast a FOXDELTA oldaláról.

Ennél nincs semmi egyéb konfig a parallel port környékén? Mert nem múkodik.

Gondolok olyanra hogy ECP vagy EPP, rendszereszközöknél esetleg valami? Vagy inkább használjam külső adapterről?

A WINPIC800-hoz a beállítások megvannak az eszközhöz, de semmi. :(

És ahogy nézegettem a neten, ezt az eszközt egy páran már elkészítették. Úgyhogy szerintem olyan sz@r nem lehet.

0

Vote up!

You voted ‘up’

ppeti84
ppeti84 picture

Szia.
Ez a legegyszerűbb egyszer használatos égető szerintem.
Én is ezzel égettem be az enyémbe a programot anno.
http://users.atw.hu/wattmep/WLPT_Vpp_Mini_v4/WLPT_Vpp_mini_v4.html

Üdv: Peti

0

Vote up!

You voted ‘up’

More similar content