You are here

TP-Link 841N v8.2 felélesztése soros portról nem megy (megoldva)

17 posts / 0 new
Last post
Watt768

Üdv!

Van nálam egy, a tárgyban szereplő router, ami jelenleg papírnehezékként használható csak. :) A hibajelensége, hogy folyamatosan újraindulgat. Rákötöttem soros portra, hogy belenézzek mi zajlik le induláskor. Putty kliensben rendre megjelenik a boot folyamat, amikor kiírja, hogy Autoboot in 1 seconds, itt kellene begépelnem egy "tpl" parancsot enter nélkül, ami megállítja a kernel indulását, de maga a parancs nem megy át a CPU-ba. Most jön az elektrós része. A panelen a TX kivezetés tökéletesen működik, mivel szöveg van a terminálban. Az RX láb gázos csak nem tudom miért. Előtúrtam egy régi P3-as gépet aminek az RS232 portját használom MAX 232-vel illesztve. A panelen lévő Rx kivezetésen nincs felhúzó ellenállás a 3v3 tápra, 1 nulla ohmos ellenálláson keresztül közvetlenül befut a CPU-ba (elvileg, ha csak nem hiányzik a tok alól a pad). Felhúztam 10k-val az Rx-et, de így sem veszi a parancsot, le is kötöttem róla. Putty-ban a flow control ki van kapcsolva és még sem reagál Rx-re. Az illesztő usb 5V-ról megy. A routeren RX-TX-GND van használva.
Van valakinek ötlete?

Comments
GeryMix

B verzió: vagy elküldöd nekem postán és én javítva visszaküldöm. De mint írtam, a módszerrel amit leírtam nem kell semmit sem bepötyögni, így jó az eddigi illesztőd is. Írj majd hogy mi van.

0

Vote up!

You voted ‘up’

Watt768

Üdv!
Na sikerült :) A reset gombos megoldás nem jött be, és a címzések is eltérnek az openwrt-n írtaktól. Gyári firmware tartalmaz bootloadert, az nem kell. Openwrt-s image került vissza.

v8.2-re érvényes:

wasp>tftp 0x81000000 firmware.bin
done
Bytes transferred = 3932160 (3c0000 hex)
wasp> erase 0x9f020000 +0x3c0000
wasp> cp.b 0x81000000 0x9f020000 0x3c0000
Copy to Flash... write addr: 9f020000
done
wasp> bootm 0x9f020000
## Booting image at 9f020000 ...
Uncompressing Kernel Image ... OK

Starting kernel ...

Üdv,
Watt768

0

Vote up!

You voted ‘up’

Watt768

Üdv!
Kínlódok még vele, a másik illesztőt már elbontottam :) Hétvégén meglesem újra, ha nem sikerül, akkor küldöm.
Üdv,
Watt768

0

Vote up!

You voted ‘up’

formasu
formasu's picture

Szia!
Képes volnál elküldeni? Posta ide-oda, + biztosan anyag is kell valami, a munkáról nem is beszélve, de biztosan valamennyi abból is kell. Ennyiért már bemész egy boltba, és veszel újat, 5 év garival...... Nagyon "megszállott" lehetsz, de ez még tanulópénznek sem éri meg!

Üdv: formasu

0

Vote up!

You voted ‘up’

GeryMix

A routeren nyomd meg a reset gombot 1 másodpercre, mialatt putty alól nézed soros porton. Ez megállítja az újraindulást és elindítja a firmware recoveryt, ha a boot még épségben van. Látni fogod, hogy milyen fájl nevet kér a recoveryhez. Ezután letöltöd a LEGRÉGEBBI firmware-t a gyártó honlapjáról (vagy dd-wrt-t), kicsomagolod és átnevezed arra a névre amit a router recoveryje vár a frissítéshez (a puttyban látod). A PC hálókártyájára beállítod azt az ip-t amit a puttyban látsz (server IP)(ha jól rémlik 192.168.0.100), maszk: 255.255.255.0, átjáró nem kell. A router LAN2 portját összekötöd a PC hálókártyájával, a TFTP32-t elindítod, beadod az átnevezett fájlt, és a frissítés el fog indulni amit a puttyban látni is fogsz. Így nem kell semmit sem bepötyögni.

0

Vote up!

You voted ‘up’

Watt768

Üdv!
Amint kész lesz a normális illesztő, megnézem újra :)
Üdv,
Watt768

0

Vote up!

You voted ‘up’

formasu
formasu's picture

Szia!
Foglalkozol vele közel egy napja, méregetsz, /gondolom, tudod, hogy mit, és miért/ keresel, ......
Egy ilyen készülék új ára: 5 e Ft alatt van! Lehet, hogy sok az időd, de szkóp az nincs. Így van értelme?
Bocs.

Üdv: formasu

0

Vote up!

You voted ‘up’

Watt768

Üdv!
Az idő nem gond, mert saját cucc. Tudnám nélkülözni, de jó lenne helyrepofozni, mivel én vágtam tönkre :D Szkóp csak holnaptól lesz, az többet mond majd.
Üdv,
Watt768

0

Vote up!

You voted ‘up’

kojot

Mérd végig akkor az Rx-et. Ui a 740-nél nem csak kábelt kell betenni, hanem kell egy átkötés is. Direkt lefelejtették róla. Lehet látni, hogy nem vezet az adott lábhoz semmi csak két pad egymás mellett. Másik dolog, a Max232 re/ről és a 3.3V-ot a routeren használd! Ha az nincs rákötve az is gubancos lehet.
Lásd: http://wiki.openwrt.org/toh/tp-link/tl-wr740n#serial

0

Vote up!

You voted ‘up’

Watt768

Üdv!
Bekötöttem a router 3.3V-jára az IC-t, de ugyan úgy nem megy a parancsküldés. Szkóp hiányában teszek rá holnap legalább ledeket :) Az nem tudom számít-e, hogy a MAX232 5V TTL-RS232 nekem pedig 3.3V-ról kell illeszteni.
Üdv,
Watt768

0

Vote up!

You voted ‘up’

Oszi11
Oszi11's picture

Szia!

A MAX232 ajánlott tápfeszültség-tartománya 4,5V...5,5V, nem jó ötlet 3,3V-ról járatni. Az amelyik tudja a 3,3V-ot is MAX3232-nek hívják.

Próbáld meg ezt:

Üdv,
Oszi

0

Vote up!

You voted ‘up’

kojot

Én valami ilyesmit használok, és az elérendő eszközről táplálom, nem egyéb külső tápról. Így biztosan nem lőhetem túl soha. Számtalan alkalommal használtam már. Igen ez a hagyományos felépítés, semmi külön trükk.
http://sodoityourself.com/wp-content/uploads/2007/02/circuit_232.jpg

0

Vote up!

You voted ‘up’

Watt768

Üdv!
Én most hétvégén készítettem egy doksit MAX3232-re az univerzális 3.0V-5.0V-ig jó, a nyákja kompatibilis a 232-vel. Jelenleg IC-re várok. Tranzisztorossal próbáltam, de meg sem nyikkan. A MAX232 "A" jelölésű elvileg még megy 3.3V-ról csak lassabb sebességgel. Nekem sima van, tuti ez a gond. Nem kell ide szkóp sem :) A TX-RX kivezetés közvetlenül befut a CPU-ba, csipogóval megnéztem.

Üdv,
Watt768

0

Vote up!

You voted ‘up’

Kari

Haho!
Te most ugye csak (kicsit) viccelsz!? :roll: Popov elvtars man elegge regen feltalalta az adatlapot, s el vele a nagyvilag! Hinni meg mèg mindeg csak a nagymisen szokas, de ott sem kötelezö_mondhatnank haman az exaktnak nevezett szakagak egyiket müvelgetjük. 5V+/-0,5V a speckoja!...
Jobbat! Kari

0

Vote up!

You voted ‘up’

Oszi11
Oszi11's picture

Szia!

Nem értem, azt írod a parancs megállítja a kernel betöltését, akkor megkapja nem?
Az OpenWrt oldalán és a fórumban lehet találni hasznos infót!

http://wiki.openwrt.org/toh/tp-link/tl-wr841nd

Üdv,
Oszi

0

Vote up!

You voted ‘up’

Watt768

Üdv!
Úgy értem meg kellene állítania, csak nem jut át valamiért, vagy figyelmen kívül hagyja a parancsot. A kernel halott, ezért mindig rebootol. A linkelt oldalt már átolvastam és a fórumát is, sőt egész nap a netet túrtam infóért, de eddig nincs siker :) Com monitor szerint okés a Tx. Szkóp most nincs, hogy ránézzek az illesztő utáni Rx oldalra.
Üdv,
Watt768

0

Vote up!

You voted ‘up’

More similar content